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APPENDIX A.  HINTS WHEN USING EXCEL 
 

This appendix provides hints when using Microsoft Excel.1 Appendix A includes general 
features that are useful in all the applications solved with Excel in the book, Introduction to 
Chemical Engineerin Computing, 2nd ed., Bruce A. Finlayson, Wiley (2012). Appendix A in the 
book is much abbreviated, but this appendix gives additional detail that is useful to beginners.  
Other features are illustrated in the context of specific examples, and a list of them is provided at 
the end of Appendix A for handy reference. For a more detailed description of Excel, consult 
other books devoted to Excel. 

 
INTRODUCTION 
 
A workbook is composed of several sheets, which are named Sheet1, Sheet2, etc. at the bottom. 
You can reference cells in any of the sheets, but here we work with only one sheet. Cell 
organization. The rectangular array of cells is labeled A, B, C, D … across the top, and 1, 2, 3, 4, 
… down the left-hand side.   See Figure A.1. Cell B3 is in the second column (B column) and the 
3rd row from the top.  (As in linear algebra with matrices, columns go down and rows go 
across.)  Cell contents.  You can enter a number, word, or formula into the cell.  To enter a 
number, click on the cell and type the number.  Pressing return will move down one cell, 
pressing tab will move across one cell – to be ready for the next entry.  To enter a word, select 
the cell and type the word.  The word can also be preceded by a single quote, which is useful if 
the ‘word’ is actually a number.  To enter a formula, select the cell, enter = followed by the 
formula.  The cell can be referenced by its location, e.g. B1, but it can also be named.  To name 
it, select the cell and enter the name of the variable in the upper left-hand corner of the 
spreadsheet and then press return or enter.  Then to use the value in B1, you can use the variable 
name ‘temperature’ rather than B1, as in Figure A.1. Columns A and C are for identification only 
The entries in column B are:   
 B1 is named temperature (A.1)  
 B3 is: ‘1 – 0.01*temperature (A.2) 
 B5 is: = 1 – 0.01*temperature (A.3) 

 
 

 

                                                                    

1  Excel is a registered trademark of Microsoft Corporation, Inc. 



Introduction to Chemical Engineering Computing – Copyright, Bruce A. Finlayson, 2004-2011 295  

 

 
 

Figure A.1. Cell contents: (a) naming cell, formulas, text; (b) view using Show Functions 
 

The second figure A.1 shows what is typed in the cell B5. You can see that by choosing the 
Formulas Tab and then Show Formulas in the Formula Auditing Group. 
 
 When Excel opens, there will be several tabs across the top, and these are described 
below. It is easy to find out what each one does: simply put your cursor above one of the 
commands and an explanation appears, along with a link to more information. You can also use 
the question mark in the upper-right corner, . 
 

When you open Excel, there are a number of tabs across the top. The first one is 
File. If you click on that, you get Figure A.2. Here you can save your document, 
close it, open another one, print, etc. Notice particularly the Options near the 
bottom. Click on it and then click on Add-Ins. You want to be sure that the 
following are Active Applications: Analysis Toolpak, AspenPlus V7.2 Excel 
Calculator, Aspen Simulation Workbook V7.2, and Solver Add-in. If they are 
not active, select them and choose Go. If they don’t appear, use your original 
DVD or see your system administrator. 

 
 
 
 
 
 
 

 
Figure A.2. File Tab 
 

 

 
 

 
Figure A.3. Home Tab 
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 Each tab has a number of groups. The home tab has groups: clipboard, font, alignment, 
number, etc.; see Figure A.3. With the Clipboard Group you can select some cells (from this 
spreadsheet or another open one) and paste them. Select by copying from the upper left to lower 
right and choose copy or CTRL-C (or -C on the Macintosh).  Under Paste there are a number 
of options: to paste only the numbers, or the formulas, or both, e,g, The Font Group allows you 
to change the font face, size, color, bold, etc. The Alignment Group allows you to align the cell 
entry to the left, center, or right. If you make one row bigger (click on the line under one row and 
drag it down) you can see that your can also display the entry at the top, center, or bottom of the 
cell. The wrap text option is useful if you have a long entry and want it displayed on more than 
one line. The Number Group lets you select how you want the numbers displayed: the number of 
significant digits, commas or not, $ or not, etc. If you select a cell, you can use fewer significant 

digits by clicking the symbol to decrease by one each click, or the symbol to increase 
by one each click. By clicking the arrow in the lower right corner of the Numbers Group you can 
change the format, alignment, number of digits displayed, etc. The Conditional Formating option 
in the Styles Group allows you to have the color of the cell contents change depending upon a 
condition, for example if a parameter meets certain conditions. This can be used as a red flag 
(literally!) to highlight mistaken results or mistaken input and provides a form of data validation. 
In the Cells Group you can insert a cell, row of cells or column of cells. With delete you can do 
the reverse. The format option is useful for renaming a sheet (you can also select the name at the 
bottom and type a new one) and to protect part or all of the worksheet from changes. The Editing 
Group allows you to easily average some cells, or display the maximum value of a group of 
cells. You can clear the contents of a cell, To copy cells down, click on a cell and choose Fill 
down. The contents of the cell above is copied down. If the cell above has a formula, the formula 
is copied down, incrementing the row number by one. You can also select the lower right corner 
of a cell and copy down, too. Suppose the original formula used B2.  If the formula is dragged to 
the right, B2 is changed to C2. If the formula is dragged down, the B2 is changed to B3. If you 
don’t want that to happen, i.e. you want the formula in all columns to use B2, then use absolute 
addresses.  In the formula, change B2 to $B$2. Options like $B2 and B$2 are also possible.  If 
you select a cell tag in the equation and press F4, it turns into an absolute address.  On the Apple 
Macintosh selecting the cell tag and pressing command-T ( -T) does the same thing; if you 
continue to press it, the tag cycles between B2, $B$2, B$2, $B2, B2. To insert a new row, select 
a row on the left-hand side and choose Insert/Row.  A new row is placed above the one you 
selected.  The cells are renumbered, and all the formulas are changed, too, to reflect the new 
numbering system.  Use this same method to insert a column; the new column will appear to the 
left of the one you have selected. 
 
CALCULATION 
 
 In the Formulas Tab (Figure A.4), Function Library Group, you can find a number of 
functions in Math & Trig. These include cos, cosh, acosh, ln, log10, etc. More Functions has 
engineering functions such as Bessel functions. Show Functions (to the right of Trace 
Precedents) will display all formulas rather than the calculated results. This option was used to 
prepare Figure A.1.b. Calculation Options allows you to choose Automatic (the spreadsheet will 
recalculate every time you change one cell) or Manual (the spreadsheet will wait until you 
choose Calculate Now (for the whole workbook) or Calculate Sheet (for only the sheet showing). 
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This is sometimes useful when solving a problem in which the formulas are intertwined and the 
formula in one cell depends on the answer in another cell, which depends on the value in the first 
cell.  In these cases it is convenient to turn off iteration while preparing the formulas in the 
spreadsheet, and then turn it on once the entire spreadsheet is complete. 
 

 

 
 

Figure A.4. Formula Tab 
 
 In the Data Tab, the Sort & Filter Group has an option to Sort. The icon with a downward 
pointing arrow will cause the smallest values to be at the top. The icon with an upward pointing 
arrow will cause the largest values to be at the top. The other icon allows you to sort several 
columns based on the values in one of the columns.  Select the columns and click it; a window 
appears; you can sort according to one of the columns and the other columns will be sorted as 
well. 

  
Figure A.5. Data Tab 

 
 You can use Goal Seek to find the value of a variable to make an equation zero (or some 
other number. For example, the cell D3 is defined as ‘=x*x-2*x. The cell C3 is named x. The 
starting value of 3 is placed in cell C3. Open What-If Analysis in the Data Tools Group; see 
Figure A.6. In this case, the variable (x or C3) will be varied until the formula (D3) gives zero. 
The result is x = 2 and D3 displays 0.000139.   This is not very accurate and Solver can be used 
instead. 
 

 
Figure A.6. Goal Seek 
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 If Solver has been supplied as an Add-In (see above), the word Solver is seen in the 
Analysis Group. This program is a sophisticated program to solve nonlinear equations. Decide 
on a cell that you wish to have a certain value (such as zero); this is the function cell. Select 
another cell that will be changed to achieve this; call it the variable cell. Select the function cell 
and choose Solver in the Analysis Group. Figure A.7 shows the window. The cell D3 is defined 
as ‘=x*x-2*x. The cell C3 is named x. The starting value of 3 is placed in cell C3. In this case, 
the variable (x or C3) will be varied until the formula (D3) gives zero. The result is x = 2 and D3 
displays -5.5E-07. If the answer is not accurate enough, you can change the Constraint Precision 
to a value you think is reasonable for your problem. (The default parameters are set for business 
applications, where tenths of a cent don’t matter.) When the solver window is open, choose 
Options, All Methods (see Figure A.7). You can also limit the number of iterations.  
 

    
 

Figure A.7. Solver Windows 
 
 If the spreadsheet iterates to meaningless numbers, you can reset it by using CTRL-Z or 
using the undo typing key: . 
 
 You can solve multiple equations using Solver, too. For example, if the variables x and y 
are placed in cells A1 and A2, respectively, you can put equations into cells B1 and B2 that use x 
and y. Then choose solver and set B1 to zero by varying A1 through A2 subject to the constraint 
that B2 = 0. Convergence may be difficult and this might not work. 
 
 It is possible to use Excel with Aspen (Figure A.8). The Aspen Tab is an add-in (see 
File/Options/Add-ins); using it allows you to use Excel to calculate certain things in your Aspen 
model. That procedure is beyond the scope of this book, but more information is available in the 
AspenPlusUserModel, Chapter 5.  
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Figure A.8. Aspen Tab 
 
 Two of the functions under Math & Trig are MINVERSE and MMULT.  These functions 
have the obvious use.  The inverse function, of course, must act on a square matrix, and creates a 
square matrix.  To use it, first create the matrix, as illustrated in cells A1:C3 of Figure A.9.   
Then in cell A6 type =MINVERSE(A1:C3).  You can also insert the A1:C3 by selecting the 
cells.  Click on cell A6, press the shift key, and select the other corner of the matrix, C8.  Press 
Function Key F2, then CTRL-Shift-Enter (CTRL-Shift-Return on the Macintosh).  The inverse 
appears in A6:C8.  The matrix multiplication is illustrated in Figure A.9 by multiplying these 
two matrices together; the result should be the identity matrix.  Click on cell A11, type 
=MMULT(A1:C3,A6:C8).  Click on cell A11, press the shift key, and select the other corner of 
the matrix, C13.  Press F2, the CTRL-Shift-Enter.  The matrix multiplication appears in 
A11:C13.  Indeed it is the identity matrix. 
 

 
 

Figure A.9. Matrix Inversion and Multiplication 
 
PLOTTING 
 
Plotting in Excel is easy.  Choose the cells you wish to plot, such as the first two columns in 
Figure A.10.  If you want, choose the headings, too, and they will appear in the graph (although 
they can later be changed).  Then choose the Insert Tab, choose XY Scatter, and click on the 
graph style you want. To label the axes, select the figure, choose Layout, Axis Titles. Click on 
the title you wish to change and type the new values. To put multiple lines on the graph, select 
more columns.  For example, if you select all three columns, you can produce Figure A.10. 
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Figure A.10. Plot of two lines 
 
 To make a contour plot or 3D view, create the data to be plotted in a rectangular part of 
the spreadsheet.  In Figure A.11 the A column and 7th row are the x and y values, respectively, 
and the other values are the ones to be plotted. Select the numbers to be plotted, choose Insert 
Tab/ChartsGraph/Other Charts and pick one of the surface plots, and choose Surface. The 
rectangular domain will be plotted as a function of the cell numbers or entry numbers, not any 
values you assigned to each row or column (see Figure A.11). Also, the plot is flipped vertically 
(note the location in the spreadsheet where the maximum occurs and the location in the plot 
where it occurs, too. There is no point in having a different increment between the x points or the 
y points, because the graph is going to be made using constant increments. This is a serious 
limitation of Excel for scientific plotting.  By right-clicking on the x-labels, you can choose 
horizontal, edit, select cells containing 15->3, and say OK. For the vertical labels, choose depth 
axis and change them one by one: the lower one is Series1 and you change it to 10; the next one 
is Series 2 and you change it to 20, etc. You can make the final result look like Figure A.11. 
 
IMPORT AND EXPORT 
 
 There are several ways to do this.  The first method works when you have a single 
column to transfer.  To export from Excel, select the column of cells, choose the Home Tab and 
then Copy, open an application that accepts text files, and choose Paste.  To get a single column 
of numbers into Excel, copy the column in another application, in Excel select one cell, and 
choose Paste. 
 
 To export multiple columns from Excel, select the columns you wish to export, Copy, 
change to another application file and Paste. To do the reverse operation, copy the text data, open 
Excel, put the cursor in one cell, and choose Paste.  If the original text file had tabs in it (is tab 
delimited), each entry will go into a different cell.  If you don’t prepare the text file  
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Figure A.11. Contour Plot 
 
 
appropriately, you may get a mess (the whole file put into one cell or one column. If you create 
several columns in Word using tabs, you can copy the columns and paste them into the 
spreadsheet and the entries will go into successive cells.  

 
You can export the contents of the spreadsheet to a text file that can be used as the input 

to another program.  This is a nice way to have a user interface for a program that requires 
significant computing capability (beyond what Excel offers).  You could put the physical 
parameters for the case you are studying into the Excel spreadsheet, allowing them to be changed 
easily.  You then export the information and have the other computer program read the text file 
to get the data.  To export the information (the contents of the cells, not the figures from the 
spreadsheet), choose SaveAs, change the format to a text formats, such as Text(Tab delimited), 
and save it. If you open that file in a word processor or text editor, you will see the information 
displayed in exactly the same format as in the spreadsheet.  It isn’t trivial to get these numbers 
into other programs, which have to read the spaces appropriately, and some knowledge of the C 
computer language may be necessary, but it does make a nice interface for a program that you 
will use many times.  MATLAB® can read such files, for example. 
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PRESENTATION 
 
The insert tab allows you to put figures and charts into your spreadsheet. One important option is 
Text Box, in the Text Group. You can draw a box on your spreadsheet (and resize it) and type 
into it whatever you want. It can be anywhere on the spreadsheet, covering multiple cells. In this 
tab in the Sheet Options Group, you can choose to show the gridlines (or not) and the headings 
(1,2,3,…,A,B,C,…) (or not). 
 
 In the Review Tab you have a chance to check your spelling, translate to a new language, 
etc. You can protect your sheet or workbook so that others cannot open it without a password, 
and you can share the workbook with others on a network so that several people can use it. The 
New Comment command allows you to fill a text box with some information that will be hidden 
until you click on it. A small red arrow is created in the upper right location of the cell to indicate 
there is a comment there. Put your cursor above the arrow and the comment is displayed. 
 
 In the View Tab the Workbook Views Group provides a variety of ways that the sheet 
can be displayed. In the Show Group, Gridlines works the same as in the Page Layout Tab: if it 
is checked, lines are shown dividing the cells, and they are not displayed if it is unchecked. In the 
Zoom Group, Zoom allows you to zoom in or out; Zoom to Selection allows you to choose a 
section of the sheet and expand it to the entire screen. Choose 100% to return to the original 
view. 

 
 In the Window Group, there are provisions for breaking the Sheet into separate parts. 
You may wish to display one column while you scroll through other columns. Put that column 
(e.g. column A) at the leftmost column shown, and choose Freeze Panes; see Figure A.12. Then 
as you scroll to see columns B -> Z -> AA -> AX, etc., column A continues to be displayed. This 
is helpful for a case in which the column represents the chemical names and properties and each 
of the other columns refers to one stream. There might be hundreds of streams and you’d like the 
first column identifying rows to remain visible at all times.  
 
 To make a professional-looking spreadsheet, it is important to provide documentation for 
the reader.  You can establish different sections, surrounded by boxes (see Figures 2.1 and A.13) 
 
 Title, your name and date 
 Data Input – these are values that the user may change 

Parameter Values – these are values that the user won’t change, but are needed (not 
shown) 

 Formulas used – this defines the problem 
 Results 
 
To make the boxes, select the cells to be enclosed, in the Home Tab, Number Group, choose the 
arrow at the bottom right, choose Border and then Outline (or some other format. 
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Figure A.12. Freeze Panes 
 
 

 
 

Figure A.13. Spreadsheet arranged for easy understanding 
 
 The Split command allows you to divide the Sheet into two vertical panels or two 
horizontal panels, or four, 2 x 2. Consider the sheet shown in Figure A.14a. Put the cursor in the 
cell C3 (value 7 showing) and choose Split. The result is shown in Figure A.14b.  Each of the 
four regions has a slide bar that allows you to scroll through it. To undo this, choose Split again. 
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Figure A.14. Split Screen 
  
 You can insert pictures, equations, and hyperlinks (to web sites), too.  Choose the Insert 
Tab. Choose Picture in the Illustrations Group and then select the picture. To enter an equation, 
Choose Equations in the Symbols Group; type the equation. For hyperlinks, simply choose 
Hyperlink in the Links Group;  and insert the web address and some text to display in the cell.  
Be sure to try it while connected to the internet to ensure that it works. 
 
 To select columns for charts, regression, and printing, put the cursor in the upper-left cell 
that you’d like to select and drag down until the shaded box covers all the columns and rows you 
want.  Note that the columns and rows have to be contiguous, or next to each other.   You can do 
this to two or more contiguous columns or rows.   Use this same procedure for selecting the print 
area. If you want to select non-contiguous columns or rows, select the first one, then hold down 
the CTRL key while you select the second one. On the Macintosh, use control-command 
(control- ) rather than CTRL.  When you paste them, only the ones selected will be pasted, 
not the ones in between you weren’t interested in. 
 
 Sometimes you want to reproduce part of your spreadsheet in another spreadsheet or in 
another area of your existing one.  You can select the area of the spreadsheet, choose Copy, 
move to the upper, left-most cell of the new area and choose Paste.  Be careful because this will 
copy all formulas, too. If you want only the values from a spreadsheet, copy the part you want 
and choose Paste Special; then choose the desired option (such as Value).  You can also paste 
into Word.  If you simply use Paste, you can manipulate the spreadsheet inside Word (resize it, 
change the font, etc.).  If you use Paste Special, one option is to paste the spreadsheet as a 
picture.  In that case the whole image is frozen before it is put into Word. 
 
 You can select a column or columns and sort them using the Data/Sort option. Simply 
select ascending or descending and choose sort. 
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APPLICATIONS OF EXCEL  
 
Listed here are applications of Excel using specific tools so you can find them easily. 
 

• Equations of state, Chapter 2, p. 14; 
• Vapor-liquid equilibrium, Chapter 3, p. 32; 
• Chemical reaction equilibrium, Chapter 4, p. 52; 
• Process simulation using Excel, simple mass balance, Chapter 5, pp. 70-73; 
• Process simulation using Excel, including chemical reaction equilibria, Chapter 5, p. 72; 
• Process simulation using Excel, including phase equilibria, file on ChemEComp.com, 
   complicated process solved with Excel; 
• Continuous stirred-tank reactor, CSTR, Chapter 8, p. 162; 
• Straight line curve fit using Excel, Appendix E, p. 316; 
• Polynomial regression using Excel, Appendix E, p. 319; 
• Multiple regression using Excel, file on ChemEComp.com,  
   parameter estimation with Excel; 
• Nonlinear regression using Excel, file on ChemEComp.com, 
   parameter estimation with Excel; 
• Finite difference method for boundary value problems, Appendix F, p. 361; 
• Finite difference method for elliptic problems, Appendix F, p. 368. 

 
  


